Présentation de l'algorithme :

Voici un algorithme ... où:
A est distance entre deux creux
B est la distance qui reste à parcourir pour arriver au bout
X est l'abscisse du foret
N est le nombre de déplacement
M est le nombre de retour en arrière complet

Tester l'algorithme :


(cliquer sur le bouton ci-dessus pour lancer ou relancer l'exécution de l'algorithme)

Résultats :

Code de l'algorithme :
1     VARIABLES
2       A EST_DU_TYPE NOMBRE
3       B EST_DU_TYPE NOMBRE
4       X EST_DU_TYPE NOMBRE
5       N EST_DU_TYPE NOMBRE
6       M EST_DU_TYPE NOMBRE
7     DEBUT_ALGORITHME
8       LIRE A
9       X PREND_LA_VALEUR 0
10      N PREND_LA_VALEUR 0
11      M PREND_LA_VALEUR 0
12      B PREND_LA_VALEUR 1-X
13      TANT_QUE (B!=0) FAIRE
14        DEBUT_TANT_QUE
15        SI (B>=A) ALORS
16          DEBUT_SI
17          N PREND_LA_VALEUR N+1
18          X PREND_LA_VALEUR X+A
19          FIN_SI
20        SI (B<A) ALORS
21          DEBUT_SI
22          X PREND_LA_VALEUR A-B
23          N PREND_LA_VALEUR N+1
24          M PREND_LA_VALEUR M+1
25          FIN_SI
26        B PREND_LA_VALEUR 1-X
27        FIN_TANT_QUE
28      AFFICHER "Distance entre 2 creux A= "
29      AFFICHER A
30      AFFICHER "Nombre de déplacements N= "
31      AFFICHER N
32      AFFICHER "Nombre de retour en arrière M= "
33      AFFICHER M
34      AFFICHER "Nombre de creux N+1= "
35      N PREND_LA_VALEUR N+1
36      AFFICHER N
37    FIN_ALGORITHME